اتصال شبکه های Ospf و Eigrp در Packet Tracer

1

اتصال شبکه های Ospf و Eigrp

در این سناریو که در نرم افزار packet tracer طراحی شده است میخواهیم طریقه اتصال شبکه های ospf و eigrp را بررسی کنیم که طرف راست شبکه که از طریق پروتکل مسیریابی ospf تنظیم شده و به سمت پروتکل Eigrp متصل شده است.

 

 

سناریو

 

 

ip  های تنظیم شده در تصویر به از چپ به راست این صورت می باشد:

EIGRP

labtop : 172.16.11.10 255.255.255.0

۲۵۵.۲۵۵.۲۵۵.۰ ۱۷۲.۱۶.۱۱.۱ : router 1 fas0/0

router 1 serial 0/0 : 10.0.0.6 255.255.255.252

OSPF

router 2 serial 0/0: 10.0.0.5 255.255.255.252

router 2 serial 0/1 : 10.0.0.2 255.255.255.252

router 3 serial0/0 : 10.0.0.1 255.255.255.252

router 3 fas 0/0 :192.168.1.1 255.255.255.0

pc: 192.168.1.10 255.255.255.0

نکته

خوب در ابتدا باید این نکته را به خاطر سپرد که بر خلاف سوییچ ها که پورت های آن ها به طور پیش فرض روشن است در روتر ها باید پورت ها رو به طور دستی و با دستور روشن کنیم

وارد روتر اول میشویم و به پورتی که به لبتاب وصل شده ip میدهیم.

r1>en

r1#conf

r1(config)#interface fastEthernet 0/0

r1(config-if)#ip address 172.16.11.1 255.255.255.0

r1(config-if)#no shutdown

به پورتی که به روتر دوم متصل شده ip میدهیم.

r1(config)#interface serial 0/0

r1(config-if)#ip address 10.0.0.6 255.255.255.252

r1(config-if)#no shutdown

این دستورات برای راه اندازی پروتکل مسیریابی EIGRP در روتر ۱ است.

r1(config)#router eigrp 1

r1(config-router)#network 172.16.11.0 0.0.0.255

r1(config-router)#network 10.0.0.4 0.0.0.3

حال در روتر دوم بعد از دادن ای پی ادرس شبکه های متصل را در پروتکل ospf وارد میکنیم.

r2(config)#interface serial 0/0

r2(config-if)#ip address 10.0.0.5 255.255.255.252

r2(config-if)#no shutdown

r2(config-if)#ex

r2(config)#interface serial 0/1

r2(config-if)#ip address 10.0.0.2 255.255.255.252

r2(config-if)#no shutdown

راه اندازی ospf

r2(config)#router ospf 1

r2(config-router)#network 10.0.0.4 0.0.0.3 area 0

r2(config-router)#network 10.0.0.0 0.0.0.3 area 0

نوبت به تنظیم روتر سوم میرسد.

 

r3(config)#interface serial 0/0

r3(config-if)#ip address 10.0.0.1 255.255.255.252

r3(config-if)#no shutdown

r3(config-if)#ex

r3(config)#interface fastEthernet 0/0

r3(config-if)#ip address 192.168.1.1 255.255.255.0

r3(config-if)#no shutdown

r3(config-if)#ex

r3(config)#router ospf 1

r3(config-router)#network 10.0.0.0 0.0.0.3 area 0

r3(config-router)#network 192.168.1.0 0.0.0.255 area 1

خوب برای تنظیم ای پی pc طبق عکس زیر عمل میکنیم.

 

ای پی کامپیوتر

و برای لب تاب هم به این صورت

ای پی لبتاب

وقتی به این مرحله رسیدیم باید بتوانیم از لب تاب ۱۷۲.۱۶.۱۱.۱ را پینگ کنیم و در pc هم ۱۹۲.۱۶۸.۱۱.۱

برای اتصال شبکه های Ospf و Eigrp باید ابتدا در هر دو روتری که مسیر یابی ها متفاوت هستند و با یکدیگر همسایه هستند ( یعنی روتر ۱  و روتر ۲)  استاتیک روتی تعریف کنیم که خروجی شبکه را معرفی کند. سپس در قسمت دستورات پروتکل ها دستورات مربوطه را اضافه میکنیم.

روتر ۱:

r1(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0

r1(config)#router eigrp 1

r1(config-router)#redistribute static

روتر ۲:

r1(config)#ip route 0.0.0.0 0.0.0.0 serial 0/0

r2(config)#router ospf 1

r2(config-router)#default-information originate

حال بعد از وارد کردن تمام دستورات باید امکان ping کردن pc توسط لبتاب یا بالعکس فراهم باشد.

 

لبتاب

مطالب مرتبط
1 نظر
  1. آرش می گوید

    با سلام
    فکر کنم در مرحله آخر دستورات را اشتباه نوشتید چون پینگ نمیکنن دو تا شبکه ها به هم

ارسال یک پاسخ

آدرس ایمیل شما منتشر نخواهد شد.