آموزش بکاپ گیری خودکار از میکروتیک و ارسال به FTP سرور

0

یکی از مهمترین مباحث در شبکه، بکاپ گیری منظم از اطلاعات و تنظیمات میباشد.

امروز با آموزش بکاپ گیری خودکار از روتر میکروتیک و ارسال آن به یک FTP سرور در خدمت شما هستیم. در این روش روتر میکروتیک به صورت اتوماتیک در زمانهای مشخص بکاپ گرفته و به سمت  FTP Server ارسال خواهد کرد.

این روش زمانی که تعداد روتر ها زیاد و گرفتن بکاپ دستی از تک تک روترها به صورت جداگانه کاری زمانبر میباشد، کار را سهل میکند.

به منوی system رفته سپس Scripts رو باز کنید.
در بالا سمت چپ پنجره Script List علامت مثبت را بزنید تا پنجره جدید new script باز شود و در داخل آن کد زیر که مربوط به ایجاد backup و ارسال آن به FTP Server را وارد کنید.

در کد زیر در قسمت  address، IP Address مربوط به FTP Server خود و در قسمت user و Password اطلاعات کاربر مربوط  FTP Server خود  و شماره پورت FTP را وارد کنید.

 

 

log info “Starting Automatic Backup Script Configure By cr0c0dil3”

:global thisdate [/system clock get date]

:global datetimestring ([:pick $thisdate 0 3] .”-” . [:pick $thisdate 4 6] .”-” . [:pick $thisdate 7 11])

/system backup save name=”$[/system identity get name]_$datetimestring”

:log info “Please wait…!!!”

:delay 5s

:log info “Sending Backup Mikrotik to FTP Server………….”

/tool fetch address=192.168.1.100 src-path=”$[/system identity get name]_$datetimestring.backup” user=TechTik password=TechTik port=21 upload=yes mode=ftp dst-path=”$[/system identity get name]_$datetimestring.backup”

:delay 1

:log info “Finished Backup Script…!!!!”

 

حال باید یک Scheduler تعریف بکنید تا در زمان های مشخصی بصورت اتوماتیک بکاپ گرفته و ارسال بشه.
به منوی system رفته سپس Scheduler رو باز کنید در سمت چپ بالا علامت مثبت رو کلیک کنید تا پنجره New Schedule باز بشه یک نام دلخواه برای آن انتخاب کنید.
قسمت Start Date و Start Time تاریخ و ساعت شروع زمان بندی را تنظیم نمایید
در قسمت Interval مدت زمانی که بین هر تکرار باید طول بکشد را بزنید. برای مثال هر یک روز یکبار را در تصویر زیر مشاهده میکنید.
در قسمت  On Event نام مربوط به Script بکاپ را میگذاریم.

Auto-Backup-Mikrotik

مطالب مرتبط

ارسال یک پاسخ

آدرس ایمیل شما منتشر نخواهد شد.

دریافت جدیدترین مطالب در تلگرام TechTik@