نصب KVM در اوبونتو

1

قبل از نصب KVM، باید تأیید اطمینان پیدا کنید که سیستم شما از KVM پشتیبانی می کند یا خیر، چرا که برای نصب KVM  به پشتیبانی از مجازی سازی سخت افزاری در CPU است. برای بررسی سازگاری، دستور زیر را تایپ کنید:

egrep -c ‘(vmx|svm)’ /proc/cpuinfo

اگر در خروجی عدد ۰ نمایش داده شود یعنی سیستم شما از KVM پشتیبانی نخواهد کرد. اما اگر عدد ۱ یا بزرگتر از ۱ باشد یعنی KVM را در این سیستم می توان نصب کرد.Install KVM Ubuntu

 

در مرحله بعدی دستور زیر را وارد کنید  تا ۴ پکیج نصب شود.
پس از اینکه دستور را وارد کردید پسورد رو به منظور تایید باید وارد کنید.
در روند نصب ممکن است از شما سوال پرسیده شود که آیا می خواهید نصب را انجام دهید که باید حرف Y را وارد نمایید.

sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils

 

Install KVM Ubuntu

در مرحله بعد نوبت به نصب ابزاری بنام Virt-manager میباشد که بتوان به صورت گرافیکی VM ها را مدیریت کرد.

sudo apt-get install virt-manager

 

پس از نصب می توان از قسمت Application ابزار Virt-manager  را اجرا کرد.

Install KVM Ubuntu با موفقیت توانستیم KVM را بر روی Ubuntu اجرا کنیم.

Install KVM Ubuntu

مطالب مرتبط
1 نظر
  1. admin می گوید

    سلام
    من اوبونتو ۱۸.۰۴ دارم وقتی این دستور رو میزنم
    sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder bridge-utils
    این ارور رو میده
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    bridge-utils is already the newest version (1.5-15ubuntu1).
    libvirt-bin is already the newest version (4.0.0-1ubuntu8.6).
    qemu-kvm is already the newest version (1:2.11+dfsg-1ubuntu7.9).
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    ubuntu-vm-builder : Depends: python but it is not going to be installed
    Depends: python:any (>= 2.5~)
    Depends: python-vm-builder but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

ارسال یک پاسخ

آدرس ایمیل شما منتشر نخواهد شد.